The slowness and degraded performance within US0 region has been resolved. All services are now operating normally, and performance has returned to expected levels.
Posted Nov 06, 2025 - 11:02 PST
Identified
We have identified the cause of the UI slowness impacting customers in the US0 region. Our teams are actively working to mitigate the issue and restore normal service performance. While data ingest remains unaffected, recently received data may experience delays in appearing in the UI due to the slowness. This may also temporarily affect alerting behavior.
Posted Nov 06, 2025 - 10:05 PST
Investigating
We are investigating a reported issue indicating slowness and degraded performance within US0 region. As a result, some customers may experience degraded UI performance in this region.
Posted Nov 06, 2025 - 09:36 PST
This incident affected: Splunk Observability Cloud Web Interface.