Customer MTS data is delayed in creation.

Incident Report for Splunk Observability Cloud US0

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 15:21 PST

Monitoring

We have experienced an issue where MTS data creation is experiencing latency. We have identified the issue and are monitoring the service.
Posted Nov 19, 2025 - 15:18 PST
This incident affected: Splunk Observability Cloud Web Interface.