Data Management Page is not loading

Incident Report for Splunk Observability Cloud US0

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 13:09 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 13:03 PST

Update

Restoration is still in progress. Retrying to load the Data Management Page should yield positive results for some customers. Our teams continue to work diligently to resolve the issue and will provide further updates as progress is made.
Posted Feb 17, 2026 - 12:05 PST

Update

Our teams are actively working to restore services. Some customers may be seeing improvement at this time. We are committed to resolving the issue as quickly as possible and will provide updates as progress is made.
Posted Feb 17, 2026 - 11:28 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2026 - 10:50 PST

Investigating

Customers may be experiencing errors while loading Data Management Page.
Posted Feb 17, 2026 - 10:09 PST
This incident affected: Splunk Observability Cloud Web Interface and Alerting.